Oracle VirtualBox Out-Of-Bounds Write Privilege Escalation Vulnerability [CVE-2019-2867]

CVE number – CVE-2019-2867

This vulnerability allows local attackers to escalate privileges on affected installations of Oracle VirtualBox. An attacker must first obtain the ability to execute high-privileged code on the target guest system in order to exploit this vulnerability.

The specific flaw exists within the shader_get_registers_used function. The issue results from the lack of proper validation of user-supplied data, which can result in a write past the end of an allocated object.

An attacker can leverage this vulnerability to escalate privileges and execute code in the context of the hypervisor.

Oracle has issued an update to correct this vulnerability. More details can be found at:
https://www.oracle.com/security-alerts/cpujul2019.html

Jason Davies

UK based technology professional, with an interest in computer security and telecoms.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: