(Pwn2Own) Microsoft Exchange Server OAB Arbitrary File Write Remote Code Execution Vulnerability [CVE-2021-31198]

CVE number – CVE-2021-31198

Microsoft Exchange Server OAB Arbitrary File Write Remote Code Execution Vulnerability (Pwn2Own)

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Microsoft Exchange Server. Although authentication is required to exploit this vulnerability, the existing authentication mechanism can be bypassed.

The specific flaw exists within the OAB service. The issue results from the lack of proper validation of user-supplied data, which can allow arbitrary files write to OAB folders. An attacker can leverage this vulnerability to execute arbitrary code in the context of SYSTEM.

Microsoft has issued an update to correct this vulnerability.

More details can be found at:
https://msrc.microsoft.com/update-guide/en-us/vulnerability/CVE-2021-31198

Duncan Newell

Duncan is a technology professional with over 20 years experience of working in various IT roles. He has a interest in cyber security, and has a wide range of other skills in radio, electronics and telecommunications.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: